Skip to content

ZendFramework version requirements

As some people noticed, with the release of ZendFramework 1.7, the version requirement was bumped up from 5.1.6 to 5.2.4.

If you really care which ancient version of PHP you should install (vs. 5.2.6, 5.2.7 or 5.2.8 next week ;-)) -- here is a breakdown per component:

Zend_Acl: 5.0.0 
Zend_Amf: 5.0.0 
Zend_Auth: 5.0.0 
Zend_Cache: 5.0.0 
Zend_Captcha: 5.1.0 
Zend_Config: 5.0.0 
Zend_Console: 5.0.0 
Zend_Controller: 5.0.0 
Zend_Currency: 5.0.0 
Zend_Date: 5.1.0 
Zend_Db: 5.1.0 
Zend_Debug: 5.0.0 
Zend_Dojo: 5.0.0 
Zend_Dom: 5.0.0 
Zend_Exception: 4.0.0 
Zend_Feed: 5.1.1 
Zend_File: 5.2.1 
Zend_Filter: 5.1.0 
Zend_Form: 5.0.0 
Zend_Gdata: 5.1.0 
Zend_Http: 5.1.0 
Zend_InfoCard: 5.0.0 
Zend_Json: 5.0.0 
Zend_Layout: 5.0.0 
Zend_Ldap: 5.1.0 
Zend_Loader: 5.1.2 
Zend_Locale: 5.0.0 
Zend_Log: 5.0.0 
Zend_Mail: 5.1.0 
Zend_Measure: 5.0.0 
Zend_Memory: 5.0.0 
Zend_Mime: 5.0.0 
Zend_OpenId: 5.2.0 
Zend_Paginator: 5.0.0 
Zend_Pdf: 5.0.0 
Zend_ProgressBar: 5.0.0 
Zend_Registry: 5.0.0 
Zend_Request: 5.0.0 
Zend_Rest: 5.0.0 
Zend_Search: 5.0.0 
Zend_Server: 5.0.0 
Zend_Service: 5.0.0 
Zend_Session: 5.0.0 
Zend_Soap: 5.0.0 
Zend_Test: 5.0.0 
Zend_Text: 5.0.0 
Zend_TimeSync: 5.0.0 
Zend_Translate: 5.0.0 
Zend_Uri: 5.0.0 
Zend_Validate: 5.1.0 
Zend_Version: 5.0.0 
Zend_View: 5.0.0 
Zend_Wildfire: 5.0.0 
Zend_XmlRpc: 5.0.0

Zend_File is leading the list with 5.2.1 -- according to the mailinglist, the requirement is due to some tests (and essentially PHPUnit) which require 5.2.4. I generated the list using PHP_CompatInfo. I'll share the code later, since it'll go into a bigger project.

Trackbacks

No Trackbacks

Comments

No comments

The author does not allow comments to this entry